Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Important Important
    • Resolution: Unresolved
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Labels:

      Description

      You landed on this page because the game detected an error to start the game.

      We assume that the issue occurred because you are running the game on a machine (most likely a laptop) with multiple GPUs installed. In some cases the game picks the Intel (or another integrated) graphics card instead of a more powerful dedicated one and hence fails to start.

      While the game should pick the more powerful card automatically, sometimes the auto detection fails.

      Upgrading graphics card drivers (and doing a clean reinstallation of the current one)

      One possible cause for picking the wrong card are driver issues. Hence, the first thing you should try is to upgrade the drivers for all of your installed cards and if you are running already the current drivers try a clean reinstallation of these as described on this page.
      According to a user report the game failed to pick the correct card with NVidia drivers 389.12 but successfully picked the right one after upgrading to 391.25. Also issues with a driver installation proofed to be the cause for another user running into this problem who solved it by doing a clean reinstallation of his latest drivers.

      Manually tweaking the config settings

      If you have the latest drivers installed and that didn't help, the game allows you to manually select the card it should use.

      WARNING

      Note: The following instructions will change the gpu-selection behavior of the game. We DO NOT suggest to change this value unless absolutely necessary to be able to start the game. You should rather always prefer to keep that value at 0 (default - auto select). So only adjust the value if absolutely required and try to reset it to 0 with later patches (which might provide improvements for the GPU auto selection to better identify the proper graphics card without the need to explicitly set it through the config file.

      1. locate the game's user directory (open the Windows explorer and go to %UserProfile%\Documents\Egosoft\X4)
      2. if you run the game from Steam, there should be a subdirectory just consisting of numbers (like 123456789) which corresponds to your SteamID. Switch to that sub directory. (If you are running the game through GOG, skip this step).
      3. make a backup of your existing config.xml file (if it exists)
      4. replace the config.xml file with this version
      5. try to start the game again
      6. if the game doesn't start, open the config.xml file with your favorite text editor (Notepad will work just fine) and locate the line which reads: "<gpu>2</gpu>"
      7. replace the number 2 with a 1
      8. save the file
      9. try to start the game again
      10. if the game still doesn't work and you have more than 2 graphics cards installed, try to repeat the test and increment the number every time up to the number of graphics devices you have

      Once you are in-game you can verify the selected graphics card in the options menu under graphic settings. "Graphics Card" there reports the selected graphics card:

      Requesting further support

      If you followed these steps and the game still doesn't run for you and still redirects you to this page, please contact us at prioritysupport@egosoft.com (Subject: "X4-18 - Intel startup error") with your DirectX diag and Vulkan info attached. This wiki entry explains how to create this information.

      Alternative Workaround

      If the above steps don't work, you can try to disable the integrated GPU in your system (and only have the dedicated GPU enabled). This can be done by disabling the integrated GPU in the Windows device manager. Doing that should enforce X4 to pick the right GPU on your system.

        Activity

        Hide
        added a comment -

        nice game. first launch as startup error.

        Show
        added a comment - nice game. first launch as startup error.
        Hide
        Stefan Hett added a comment -

        Instructions were updated, adding the note to try out a reinstallation of the current drivers (which proofed to solve the issue for at least one user running into this problem).

        Show
        Stefan Hett added a comment - Instructions were updated, adding the note to try out a reinstallation of the current drivers (which proofed to solve the issue for at least one user running into this problem).
        Hide
        added a comment -

        Continued from directly above. This is super annoying because I actually BOUGHT the GPU to play this game. Please advise. The recommended ```config.xml``` with GPU values monotonically increased from 1 to 4 (I overdid it just to check, there are only two) resulted in the exact same popup attached.

        Show
        added a comment - Continued from directly above. This is super annoying because I actually BOUGHT the GPU to play this game. Please advise. The recommended ```config.xml``` with GPU values monotonically increased from 1 to 4 (I overdid it just to check, there are only two) resulted in the exact same popup attached.
        Hide
        added a comment -

        The same popup with multiple versions of the gpu field of the config.xml changed.

        Show
        added a comment - The same popup with multiple versions of the gpu field of the config.xml changed.
        Hide
        added a comment -

        Uninstallation of X4 Foundations and deletion of the entire ```Documents/Egosoft``` directory. Reinstalled the game (a 6 hour 10Gig download over poor hotel wifi I might add). The major system change that precipitated this crashing behavior was the addition of an external GPU housed in a Core V2. The game previously ran using the existing internal dedicated Quadro GPU.

        What is going on with this game that the addition of a GPU (as the only system change) causes this behavior? Are there not many people playing this game that this use-case had not be addressed? I am eager to play but the fragility of the game is disconcerting and it will soon mean a request for refund.

        Show
        added a comment - Uninstallation of X4 Foundations and deletion of the entire ```Documents/Egosoft``` directory. Reinstalled the game (a 6 hour 10Gig download over poor hotel wifi I might add). The major system change that precipitated this crashing behavior was the addition of an external GPU housed in a Core V2. The game previously ran using the existing internal dedicated Quadro GPU. What is going on with this game that the addition of a GPU (as the only system change) causes this behavior? Are there not many people playing this game that this use-case had not be addressed? I am eager to play but the fragility of the game is disconcerting and it will soon mean a request for refund.

          People

          • Assignee:
            Stefan Hett
            Reporter:
            Stefan Hett
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: