Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Important Important
    • Resolution: Unresolved
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Labels:

      Description

      You landed on this page because the game detected an error to start the game.

      The issue occurred because the UI system failed to be initialized.

      Interfering 3rd-party tools

      One possible cause for this problem is 3rd party software interfering with the game to load required DLLs. The DLL the game tries to load is located under ui/core/lualibs and is called utf8_64.dll. If the game is prevented to load the DLL, the game won't start and rather terminate with this exitcode. Check if you have any such 3rd-party tool installed and see if disabling it solves the issue.

      Missing/Damaged utf8_64.dll

      To rule out a possible missing or damaged DLL, please verify the game file integrity as described on this page.

      Mods breaking the options menu script

      The options menu script is a vital part of the UI which also provides the start menu functionality. If a mod breaks that script, this exitcode is expected and the popup error will state the following error:

      Initialized UI but addon 'ego_gameoptions' is not loaded.
      

      This is expected behavior in this case and you need to fix the problematic mod by either fixing the bug which breaks the script or by removing the problematic mod.

      Further Support

      If you are certain that no 3rd-party software interferes with the game and the file integrity is reported to be all good, please do the following:

      • start the game with the additional command line parameter: /windowed /logfile log.txt
      • verify that the log.txt file was created in the X4 My documents folder (same location as where savegames are stored)
      • send a mail to prioritysupport@egosoft.com with the subject set to "X4-454 - exitcode 1003". In the mail please attach the following information:
        • the log.txt which was created above
        • a screenshot of the popup which shows the exitcode
        • state whether you performed the file integrity check or not
        • state whether (and which) 3rd-party (security) tools you are using and whether you tried to run the game without these being enabled
        • state whether you have any mod(s) installed and provide a list of these mods (if any)
        • state when the issue occurs for you (in other words: whether you experience this as a startup problem where the game doesn't start at all or whether it crashes in game)

      We will then get back to you with further steps to track down the cause of the issue.

      Historical note

      While the issue always did exist, it surfaced differently in older versions of the game.
      As of 3.20 Beta 2 Hotfix 1 affected users are redirected to this troubleshooting page.
      Before that, different effects could be observed including:

      • game started but no start menu was visible (only the background scene was shown)
      • game crashed and didn't redirect to a troubleshooting page
      • game crashed and players were incorrectly directed to X4-2
      • game crashed and players were directed to X4-297

      In 3.30 Hotfix 1 Beta 1 the main cause triggering the problem in previous versions was resolved.

        Issue Links

          Activity

          Hide
          added a comment -

          please check, cant open game now

          Show
          added a comment - please check, cant open game now

            People

            • Assignee:
              Stefan Hett
              Reporter:
              Stefan Hett
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: