Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Important Important
    • Resolution: Unresolved
    • Affects Version/s: 1.0
    • Fix Version/s: None

      Description

      You landed on this page because we have detected a crash in "X4 - Foundations".

      The issue occurred because the GFX engine failed to create a so called render target.
      Note that this can happen in both scenarios: Upon starting the game (startup error) or while the game is running (crash).

      We are currently investigating the conditions which can trigger this crash.

      Potential fix (when running into this while starting the game)

      If you want to give the following a try, see if resetting your game's config file or using the 'safe' config fixes this startup issue. This page explains how to do that.
      By using the 'safe' config file, you ensure that the game tries to start at the lowest supported resolution with the lowest graphics card settings. That way you can resolve the issue, if the GPU simply lacks enough VRAM to run the game at higher resolutions.

      Further support / Request for details

      If you run into this problem and want to help us to determine the cause, please send a mail to crash@egosoft.com with the subject set to: "X4-522 - rendertarget creation failure", add the crashdump file to your report (this page explains how to locate the crashdump file) and also add the vulkaninfo and dxdiag (see this page for instructions on how to retrieve this data).

      Issue history

      Prior to 3.20 Beta 2 Hotfix 1, players were 'incorrectly' redirected to X4-2 when this issue occurred (or not at all, if the game was running in fullscreen).
      Prior to 4.0 Beta 1 no redirect occurred when running into this issue and the game terminated with exit codes 1029-1042.
      As of 4.0 Beta 1 the game now brings up this troubleshooting page and reports a single exit code (119).

        Issue Links

          Activity

          Hide
          added a comment -

          Well, also crashes on the GTX750ti if you ask for ultra settings (which was an incredibly stupid move right?) ... which I grant you is an older card and has no business in this game... but its okay at 1080p if you don't have a large amount of ships in a sector (by large I mean 50)... still though jest making a report... cos, well whatever.

          Show
          added a comment - Well, also crashes on the GTX750ti if you ask for ultra settings (which was an incredibly stupid move right?) ... which I grant you is an older card and has no business in this game... but its okay at 1080p if you don't have a large amount of ships in a sector (by large I mean 50)... still though jest making a report... cos, well whatever.
          Hide
          added a comment -

          hie und da kann ich stunden lang spielen, andere male habe ich schon nach ein paar sekunden ein crach

          Show
          added a comment - hie und da kann ich stunden lang spielen, andere male habe ich schon nach ein paar sekunden ein crach
          Hide
          added a comment -

          Older titan x card , crashes while changing resolution from 1080p to any higher one(idk about lower resolution)

          Show
          added a comment - Older titan x card , crashes while changing resolution from 1080p to any higher one(idk about lower resolution)

            People

            • Assignee:
              Stefan Hett
              Reporter:
              Stefan Hett
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: