[X4-18] Startup Issue (unsupported Intel graphics device selected) Created: 03/Dec/18  Updated: 27/Jul/20

Status: Open
Project: X4 - Foundations
Component/s: None
Affects Version/s: 1.0
Fix Version/s: None

Type: Bug Priority: Important
Reporter: Stefan Hett Assignee: Stefan Hett
Resolution: Unresolved Votes: 0
Labels: startuperror

Attachments: XML File config.xml     PNG File graphic_settings.png    

 Description   

You landed on this page because the game detected an error to start the game.

We assume that the issue occurred because you are running the game on a machine (most likely a laptop) with multiple GPUs installed. In some cases the game picks the Intel (or another integrated) graphics card instead of a more powerful dedicated one and hence fails to start.

While the game should pick the more powerful card automatically, sometimes the auto detection fails.

Upgrading graphics card drivers (and doing a clean reinstallation of the current one)

One possible cause for picking the wrong card are driver issues. Hence, the first thing you should try is to upgrade the drivers for all of your installed cards and if you are running already the current drivers try a clean reinstallation of these as described on this page.
According to a user report the game failed to pick the correct card with NVidia drivers 389.12 but successfully picked the right one after upgrading to 391.25. Also issues with a driver installation proofed to be the cause for another user running into this problem who solved it by doing a clean reinstallation of his latest drivers.

Manually tweaking the config settings

If you have the latest drivers installed and that didn't help, the game allows you to manually select the card it should use.

WARNING

Note: The following instructions will change the gpu-selection behavior of the game. We DO NOT suggest to change this value unless absolutely necessary to be able to start the game. You should rather always prefer to keep that value at 0 (default - auto select). So only adjust the value if absolutely required and try to reset it to 0 with later patches (which might provide improvements for the GPU auto selection to better identify the proper graphics card without the need to explicitly set it through the config file.

  1. locate the game's user directory (open the Windows explorer and go to %UserProfile%\Documents\Egosoft\X4)
  2. if you run the game from Steam, there should be a subdirectory just consisting of numbers (like 123456789) which corresponds to your SteamID. Switch to that sub directory. (If you are running the game through GOG, skip this step).
  3. make a backup of your existing config.xml file (if it exists)
  4. replace the config.xml file with this version
  5. try to start the game again
  6. if the game doesn't start, open the config.xml file with your favorite text editor (Notepad will work just fine) and locate the line which reads: "<gpu>2</gpu>"
  7. replace the number 2 with a 1
  8. save the file
  9. try to start the game again
  10. if the game still doesn't work and you have more than 2 graphics cards installed, try to repeat the test and increment the number every time up to the number of graphics devices you have

Once you are in-game you can verify the selected graphics card in the options menu under graphic settings. "Graphics Card" there reports the selected graphics card:

Requesting further support

If you followed these steps and the game still doesn't run for you and still redirects you to this page, please contact us at prioritysupport@egosoft.com (Subject: "X4-18 - Intel startup error") with your DirectX diag and Vulkan info attached. This wiki entry explains how to create this information.

Alternative Workaround

If the above steps don't work, you can try to disable the integrated GPU in your system (and only have the dedicated GPU enabled). This can be done by disabling the integrated GPU in the Windows device manager. Doing that should enforce X4 to pick the right GPU on your system.



 Comments   
Comment by Anonymous [ 04/Dec/18 ]

After I disable the onboard Intel GC, the game will simply not start. It crashed and brought me here.

Comment by Anonymous [ 04/Dec/18 ]

Rebooted - and crashed again. Best not to give this disable card advice.

Comment by Anonymous [ 04/Dec/18 ]

Acer task mgr. shows 5.9 gig mem but stays at 1.5. Someone should make this clear about acer, that their stuff doesn't work.

Comment by Anonymous [ 04/Dec/18 ]

Hallo, unfortunately your suggest to deactivate the onboard GPU brought me here. FYI i tried before to force the NVidia card being used with X4 through using the Nvidia control panel and forcing the use of Nvidia card. But I don't think it worked. Although I was able to "play" X4 using I guess the onboard GPU (poor quality, nothing comparable with what I can see on online videos). I'd appreciate a fix.

Comment by Anonymous [ 04/Dec/18 ]

omg...so sad...i have a RX 570 with Intel i7 6700k (onboard deactivated...)

start --> crash --> here...

Comment by Anonymous [ 04/Dec/18 ]

Hallo,

das selbe hier, Laptop mit Intel UHD Graphics 630 onboard und NVIDIA GeForce GTX 1060 als sekundäre Karte. Das disablen der Onboard Grafik Karte brachte mich direkt hierher. Vorher hatte ich einen Freeze beim Aufruf des Startmenüs, er versuchte gerade die Hintergrundszenen zu rendern...

PS: Schön zu sehen, dass Ihr JIRA nutzt

Comment by Anonymous [ 04/Dec/18 ]

Hardware: Laptop with 8GB RAM, GTX 1060 6GB, HD Graphics 630, i5 7300. I tried disabling the intel gpu but then the game wouldn't start at all and brought me to this site. If I leave the intel gpu on the game starts and I get as far as the startmenu but after that the game freezes and chrashes. I have updated the drivers to the latest version. If i run the vulkaninfo prompt both the gtx 1060 as device 0 and the intel gpu as device 1 show up. I also tried to force the game to use the gtx card in the nvidia control panel which didn't help.

Hope this info helps and keep up the good work!

Comment by Anonymous [ 05/Dec/18 ]

I tried using the beta itself which didn't work but with the config file it seemed to work until i go to a station and try use the transport to go to the managers office or the bar for example. As soon as i enter the game freezes/gets extremely slow and I have to force quit the game. See comment before me for specs.

Comment by Anonymous [ 05/Dec/18 ]

great a 10 step fix which doesnt works , maybe you guys should have taken few months to polish the game for bugs and errors !

Comment by Anonymous [ 05/Dec/18 ]

Have the same issue. Disabling onboard GPU and start the game => crash. Re-enabling onboard GPU the game starts.

I have tried different values in the xml file...nothing change. Don't know what "<gpu>x</gpu>" stands for but I've tried 0, 1, 1000 all works if onboard card is enabled.

Comment by Anonymous [ 05/Dec/18 ]

play on the IntelHD-530 (1Gb) - 20-50fps. some crash. was more crash when i change manualy config.xml to unlock normal shadows, then dellete all configs files (only keyboard cofig live), in game reuse my favorite 1280x800 and low setings in grafics - play normaly. If crash - just dell all config files

Comment by Anonymous [ 05/Dec/18 ]

im using a radeon R9 270x i5-7500 3.40 Ghz with 8 Gb DDR4, tried all the steps and from this patch as well, game keeps redirecting me here. Maybe it has something to do with my GPU since its older?

Comment by Anonymous [ 05/Dec/18 ]

I think the fall occurs at the time of loading in the visible part

Comment by Anonymous [ 06/Dec/18 ]

Deaktivieren der onboard hat mich hierher geführt....

Bitte Egosoft, ich weiß Euch raucht der Kopf, aber fixt das irgendwie. Ich zocke seit X2 und bin an bugs gewöhnt, aber starten sollte das Spiel schon...

Ich möchte es ungern zurückgeben ...

Comment by Anonymous [ 10/Dec/18 ]

Hallo Egosoft, erstmal Dank für die bisherigen X-Spiele. Ich spiele bzw. würde gern richtig spielen auf meinem Laptop Acer Aspire 7 (A717-72G-713H) Intel Core i7-8750 2.2. 8GB RAM.
Wenn ich die Intel(R) UHD Graphics 630 deaktiviere startet nix, wenn ich aber meine NVIDIA GeForcoe GTX 1050 deaktiviert läuft das Spiel etwa 20-25min dann
stürzt es ab und ich lande hier. Wenn ich dann das Spiel neu starte und einen Spielstand lade stürzt es binnen 2-3min. wieder ab.
Starte ich jedoch das Spiel neu und lade keinen Spielstand sondern starte ein neues Spiel dauert es wieder ca. 20-25min bis es abstürzt.

Vielen Dank

Comment by Anonymous [ 01/Feb/19 ]

Bug continues to reproduce after the recommended steps above were taken.
The major system change that precipitated this crashing behavior was the addition of an eGPU (Core V2 w/ 1080Ti) to this system that already had an existing internal dedicated Quadro GPU (and integrated graphics).

Comment by Anonymous [ 06/Feb/19 ]

Uninstallation of X4 Foundations and deletion of the entire ```Documents/Egosoft``` directory. Reinstalled the game (a 6 hour 10Gig download over poor hotel wifi I might add). The major system change that precipitated this crashing behavior was the addition of an external GPU housed in a Core V2. The game previously ran using the existing internal dedicated Quadro GPU.

What is going on with this game that the addition of a GPU (as the only system change) causes this behavior? Are there not many people playing this game that this use-case had not be addressed? I am eager to play but the fragility of the game is disconcerting and it will soon mean a request for refund.

Comment by Anonymous [ 06/Feb/19 ]

The same popup with multiple versions of the gpu field of the config.xml changed.

Comment by Anonymous [ 06/Feb/19 ]

Continued from directly above. This is super annoying because I actually BOUGHT the GPU to play this game. Please advise. The recommended ```config.xml``` with GPU values monotonically increased from 1 to 4 (I overdid it just to check, there are only two) resulted in the exact same popup attached.

Comment by Stefan Hett [ 18/Jul/19 ]

Instructions were updated, adding the note to try out a reinstallation of the current drivers (which proofed to solve the issue for at least one user running into this problem).

Comment by Anonymous [ 04/Jul/20 ]

nice game. first launch as startup error.

Generated at Wed Jul 28 18:12:58 CEST 2021 using JIRA 6.2.7#6265-sha1:91604a8de81892a3e362e0afee505432f29579b0.