Skip to end of metadata
Go to start of metadata

 

This is the place for collecting problems and bugs to get them solved.

The importance describes the fail level of the issue:

  • 3: Game is still playable with the problem or is not reproducible (Autopilot issues, Graphics problem, small performance issue, writing error, ...)
  • 2: Workaround is possible or can be ignored (Ai autopilot + Station goes boom)
  • 1: Crash, Plot-Stopper, no workaround, "core meltdown" (Crash)

 

General User Interface

 

Short titleGame VersionDescription / Reproducing steps / Discussion linkImportance
Mouse disabled in main menu While pressing a key on the keyboard and you hit esc to go to the main menu you can't use the mouse to make a selection. Only arrow keys work.3
Opening the map teleports you Seems to be that sometimes going through a gate and immediately initially travel mode and switching to the map breaks you. You're teleported back to the original system you jumped from, instead of the map you get a glitch screen, and any future jumps cause you to teleport back once you open you map again. You can't get out of this state unless you reload your save.2
Landing a ship in third person mode 

I cant land a ship in third person mode. Thats cause the landing support visual isnt displayed (red dot turns green). If i enter first person mode, it instantly succedes.

https://forum.egosoft.com/viewtopic.php?f=180&t=402712 (temporary solution is get a docking computer 2 which does seem to work in third person.)

3
Crewman stats are improperly displayed Attempt to hire a crewman on a station, only Engineering and Morale are displayed.3
Menu text not displaying1.5Some text doesnt show on lower texture settings2

Graphics

Short titleGame VersionDescription / Reproducing steps / Discussion linkImportance

In map mode

Legend list is Glitching

 

Open Game --> Map --> Legend (right side on the map view, little "location" symbol)

When i move the list up and down, there are some graphic glitches.

I still works (i hope, got no other problems), but is a graphical bug.

 

3
Ultra widescreen/Tutorial does not work 

When using a Widescreen format 5760x1080 (5900x1080) the tutorial (H) does not display though

the screen changes. It just does not display the menu. Other menu's are ripped or lost in the bezel of triple

monitor setups with bezel correction (the 5900x1080); It just ins't optimized yet. There is no menu scaling option or FOV

option available to correct for the widescreen. Mission briefings are not displayed. The plot cannot be finished in widescreen (Mission from dataleak cannot be accepted, when the even happens the menus and save option become unavailable, forcing the user to quit.) Workaround for now is to play the game on a smaller/single screen so the mission briefings are displayed.

2
Graphics changes can cause UI and HUD hangups1.0

While changing from full screen to windowed mode while exiting a highway, upon reconnecting with game, the HUD is now locked in saying my speed is 972m/s (just what i happened to be

going at the time, not significant) even when sitting still. The Map menu will incorrectly display menus and sometimes will even show option which are not named but available to click. Changing to a different ship; the other ship's speed readout works fine however upon changing back the speed readout is locked still. The map menu problem persist to other ships however. Performing a restart seems to remedy. also garbled Text of the size and font as those seen in the Map Menu when

selecting a station will appear near or over text menu's and hinder game play.

3

Artificial Intelligence & Life

Short titleGame VersionDescription / Reproducing steps / Discussion linkImportance
Pilots/autopilot glitch 

After purchasing ship [smallest courier] and pilot at argon prime wharf, send pilot to Silicon Refinery to buy wafers. While on board with pilot to watch, the pilot flies into the station

and then glitches inside station through the hit box and cannot get out. Same thing with the teladi trading station in Grand Exchange IV. Other AI ships are also getting stuck.

(annoying)
Passenger Stuck Outside Ship After completing a passenger mission, after the passenger got off, it got stuck to the end of the ladder and has been stuck even while in space.(annoying)
Blackmarket 1st mission After taking the mission, the bar disappears from any and all transporters, so the goods can't be purchased or delivered.(mission breaking)
Autotrader does not work1.10cf. https://www.reddit.com/r/X4Foundations/comments/a2mtz2/autotrading_is_hilariously_broken/ - Autotrading logic sells for a loss to make shorter trips2
No Enemies after a few hours1.10Enemies generate too little resources to stand against the faction snowball. Buff enemies!2 (core system of the game)
AutoTrading Ships Become Stagnant1.3Auto trading ships will one by one purchase wares and then be stuck holding those wares when an Non Player Ship (NPS) sells to the intended destination before them. leading to a bunch of ships sitting around with full inventories of things like missile components and sometimes even hull parts. The ships don't seem to recheck if there is an available sell point for what is in their inventories and just idle around (to get picked off by pirates). having 100+ traders and going through batches of 20 every hour to manually sell these squirreled away goods is tedious and game breaking.2

Ship rebalance

Short titleGame VersionDescription / Reproducing steps / Discussion linkImportance
Overall balance seems off1.32

https://forum.egosoft.com/viewtopic.php?f=146&t=409037 and

https://www.reddit.com/r/X4Foundations/comments/a3q4ch/analysis_a_comparison_of_x3_and_x4_argon_ship/

Annoying
Paranid ships are totally OP because of their huge speed bonus1.32https://forum.egosoft.com/viewtopic.php?f=146&t=408133&p=4795428&hilit=ship+rebalance#p4795428Annoying
Drones are OP (on par with S class ships)1.32https://forum.egosoft.com/viewtopic.php?f=146&t=409037Annoying
Capital ships are underwhelming1.32https://forum.egosoft.com/viewtopic.php?f=146&t=407588&hilit=ship+rebalanceAnnoying
Fleets and wingmen basically unusable with missing travel speed matching1.32https://forum.egosoft.com/viewtopic.php?f=146&t=409037 
Launching and docking of ships and drones are WAY too slow1.32

https://www.egosoft.com:8444/confluence/pages/editpage.action?pageId=76316982

-> A catapult start system or surface docking to speed up the process

 

Other issues

Short titleGame VersionDescription / Reproducing steps / Discussion linkImportance
Uncontrollable ship after loading a save. When loading the game while the player is seated in the pilot chair, controls might not work. Workaround is to stand up and sit down again.2
Highways - Gate issue Traveling through some highways may "teleport" you to another end of the universe. More information required / see in forum.2
Repairing data leaks destroys them Occasionally for random reasons while you repair data leaks they all of a sudden get "destroyed" mid-repair process. Repairing the leaks requires the repair tool and takes two click give or take, if you see a percentage going up your actually hacking the node for a BP and if it fails the leak will blow up causing your mission to fail.

3

Yaw and Roll currently not customizable on X-52 Pro H.O.T.A.S. (and possibly other H.O.T.A.S setups) Yaw is always Z axis and Roll is always X axis on the X-52 Pro H.O.T.A.S. When the settings are changed, in control options, they either do nothing or are combined with the factory settings. This means that if you want to twist the flight stick left (Z axis -) to turn left, the ship will always roll left regardless of your settings being programmed to turn. Additionally, if you want to tilt your flight stick left to roll the ship left, which makes a whole lot of sense, the ship will always turn left. There is currently no way to undo this setting. If you try to set the digital functions for "Z axis -" to be turn left and "Z axis +" to be turn right, then set "X axis -" to roll left and "X axis +" to roll right, the ship will combine the settings together on you even though the analog controls are unmapped after doing this. For example, you twist the flight stick left and the ship both turns and rolls left simultaneously. Leaning the stick left also has the same exact effect. I have spent several hours trying to remedy this and have been unable to find a fix.2

Game hangs on autosave

 

please advise techie_man123@yahoo.com where are the friggen patches dudes!@!!!

 
Data leak repairs lead to mission failure1.10After accepting data leak repair mission from Teladi Trading Guild, in this case "Maintain Satellite Network", I successfully repair the data leak "Debris Object" and subsequently fail the mission since 'the object' was destroyed. I assume this is related to the object being linked to the mission and, since its debris, it being removed upon reaching 100% health.  Edit from other: if you have researched BP hacking the% going up is your hack and if it fails you fail the mission as the node will blow up.  remember to use the repair tool on the leaks it take few seconds and you don't have to be on top of it to use it!1 (mission breaking)
Trade item 'delivery missions' cannot be completed1.10Reproducibly, upon approaching the station where a trade item ought to be delivered to, the mission fails as "the contact was killed". - Incorrect spawning of contact, maybe?

1 (mission breaking)

Ship layout preset doesn't save the crew changes.1.10Create a new layout, save it and then add crew and save again. Then switch to other preset and change back to your custom preset. The crew will not be mentioned in the layout. This is probably a bug.2
Missing encyclopedia entries

 

 

1.10

All the factions are labeled "No information available", and many ships as well. These would be very useful for making sense of the world around us... I have no idea who these factions are or their relation to each other.

https://forum.egosoft.com/viewtopic.php?f=180&t=403873 (maybe replace this link to another unlocked)

3
Teladi Trade guild: problematic Obstacles mission. Part Fatal extraction.1.20

supposed to be extracting (reclaming) a derelict, think its either a M or L trader. Objective is to find the jumpsuit airlock and scan. there are no indicating sounds and have searched the whole ship and even clipped into it to try to find the item to scan and can find none. Even flew around the ship think you had to repair something first but that starts going into making the task very unclear. Either way there was no possible way (that i know of) to reclaim the ship breaking the mission.
Edit: attempted another reclaim mission with the trade guild same problem you find the space suit entry check, game does nothing, there are no sound prompts etc. except the the message is now change to suit scanner mode... Have been in scanner mode the whole time have looked everywhere, next selected the ship and used the scan menu item, does a green ish scan then shows blue also does nothing.

 

You have to use marines to Board the ship in Boarding pods if it is M or larger. (as of 1.2) the game and tutorial do not cover this. there is a bug where the boarding pod wont board if you are there, i have to leave the sector to get my marines to actually take the ship.-Hellguard3

This was a bug that was fixed in the 1.20 patch, where the quest gave specific commands to take over the vessel. No marines are required.

1(mission breaking)
Messages Log doesn't update after some time has passed.1.2

After some time (30 game hours) messages log stopped updating. Message's notifications still come, just that their content is no longer displayed in the messages log. The Messages are not deleted from the rear end and thus I think I reaches it's maximum capacity.

 

This is Because you have to "Clear" the log (at the bottom of the log). It is not infinite.-Hellguard3

2(Can't really analize the performance of L size miners for eg.)
Unable to complete Mission Lucrative oppertunity1.21-1.3

Have the wares have gone to the station indicated, direction marker dissapers, searched the whole station and checked all passages on lift can not find anywhere to hand the mission items in.

Edit: The Bar breaks and does not spawn if you leave the sector you get the mission from.  Retested in a clean vanilla 1.30 game. This Directly affects how you get SAC and HAT reputation which is hard enough as it is.

1(No work around, mission breaking)
Unable to create station in Argon Prime1.21-1.3Buy a land plot reletively close to the highway in the Argon Prime. The go to Plan Build menu, and as the first building select the any docking station. At this point the game will crash to desktop. Also, if you place the land really close to the highway (at the same distance as the warf), when you open the Plan Build menu, there are no station modules to select from.1

Reloading a save during boarding glitch.

1.3Saving After Boarding Party dialog is Setup and then reloading at any point during the boarding operation causes captured ship to default to the faction of the system owner when captured. A HAT Behemoth Vanguard was raiding my ships in Trinity Sanctum III, i took my Behemoth Sentinel intending to capture it. Saving beforehand as i intended to learn what i could from this encounter, ended up saving a seperate slot after the boarders had landed and when they failed i reloaded from that point. this time they succeeded but the ship turned blue and now belonged to the Paranid. I reloaded from before the boarding and redid everything figuring this must have been a glitch, and running through it all the way i captured it and it was then mine.2

When using "o" to collect dropped goods, the items sometimes will get sucked past your ship an not in your ship

1.32

I did fly a Argon Eclipse, when collecting numerous items from destroyed xenon ships or when collecting several crystals from a asteroids at the same time, the items sometimes get sucked past your ships and will not be collected.

Ship was standing still. Error is reproducable, but will not always happen. Workaround is to fly manually over the items.

2
The Deliver 3 security decryption devices mission cannot be completed.1.32After gathering the required resources and crafting the devices and landing at the requested station, no further guidance is given, nor is there a bar to deliver to, nor can I find anyone on the station.  I have saved and reloaded, taken off to check that the navigation is the same and you are directed back to the same landing pad, but still no further navigation assistance.1
Ship Mods cannot be completed1.32I have all the necessary parts and have visited a shipyard 'crafting' bench (Yes I know it's not the normal crafting bench at the trader, but cant remember exactly what you call it in game) there are options to enable paint work but no way to craft the other items (ship mods etc.)1

 

Declined (No bug of X4)

  • -

 

 

Paranid ships are totally OP because of their huge speed bonus

20 Comments

  1. Anonymous

    Feel free to provide or link a way to stream X4 even with OBS.

  2. Anonymous

    Right now, Wikipedia says you'd need 42 fingers to count the Vulkan games on your hand: https://en.wikipedia.org/wiki/Vulkan_(API)#Video_games

    Dota 2 has supported Vulkan for over 2 years, in that game, tests show that Vulkan is as fast as DX9, faster than DX11 & OpenGL. OBS has been getting requests for over 2 years to implement Vulkan game mode.

    1. Anonymous

      really like that comment.... 42 fingers on your hand (big grin) 

      1. Anonymous

        I think they meant Vulkan only games, in that case it's a lot more accurate.

  3. Anonymous

    X4 could do with some optimizing..

  4. Anonymous

    Where is the manual?

     

    1. Still being completed.

  5. Anonymous

    Doesn't it make more sense to report bugs in Jira (which is made for these things), instead of a wiki page?

    1. Never knew that existed.

    2. Anonymous

      Your are right, i updated the page.

      Reconstruction of the page will come.

       

      perahoky

  6. Anonymous

    Faction missions may missing

  7. Anonymous

    Where should I post bugs? Many numbers of players have bug with texture (and font) glitching after 15 min - 1 hour of playing, or right away after loading game in populous station with many many ships and\or NPCs. Textures become distorted like triangles, or even transparent.

    1. Anonymous

      UPD. Even people with GeForce 1070 GTX have same problem, and with many others videocards (i hear about 1060, 1050 Ti, 750Ti)

  8. Anonymous

    If I remove the default numpad binding so that numbers 1 to 9 of the numpad don't change the view anymore, the numpad numbers still change the view.

  9. Anonymous

    Even after 1.5, "trade for" stations with my M traders doesn't seem to work.  I have 6 M traders assigned to trade for, however after 1 hour they all just stopped doing anything (even if I delete all orders and reassign).

  10. Anonymous

    "Attempt to hire a crewman on a station, only Engineering and Morale are displayed." - a 3... wait, is that BY DESIGN or is it a bug and we SHOULD be seeing all the stats?

    Also honestly I wish we could use a font and fractionals that are clear, because:

    0 1/3

    looks like "one out of 3" OR "one third" ...

  11. Anonymous

    mdskript error report:

    mdscript name="Boarding"

    cue name="Infiltration_Ticker"

    <actions>

     ...

    <do_if value="not this.$killed?">

             <set_value name="this.$Progress" exact="this.$BaseProgress * (100.0f / [$Operation.marines.infiltrating.{this.$marine}.combinedskill, 1.0f].max)"/>      -  is not correct!!!

     

    must be:

             <set_value name="this.$Progress" exact="this.$BaseProgress * (20.0f * [$Operation.marines.infiltrating.{this.$marine}.combinedskill, 1.0f].max)"/>  - /Combined skill value (between 0 and 100 per individual)/ 

    (If Combined skill = 100, then  2 ticks  //  If Combined skill = 0, then  125 ticks  = 250 sec per 100% hull)

     

    ...

    what happens in reality:
    not an experienced marine make infiltration through the hull- 2-5 min
    experienced - 1 hour 40 minutes
     

    this is unnormal !

  12. Anonymous

    I have an issue with my Heracles Vanguard being stuck in build mode when the "Build Military Base Mission" it was attached to completed. Now, I have successfully completed at least five of these missions where by the base becomes the property of the faction that offered the mission. That is the build changes from green to blue.

    When I teleported to the bridge of the Builder unit a message appeared stating "insufficient funds". 

    Any suggestions on how to fix would be great.

  13. Anonymous

    I downloaded X4 Foundation and I press Start and it goes to Stop and back to Start again, hence I cannot start the game at all. Can you tell me what is wrong.

    Yours

    David Maltby

    1. Hi David, please get in touch with the support by mail. In this case I suggest to send a mail to prioritysupport AT egosoft DOT com.

Write a comment…