Skip to end of metadata
Go to start of metadata

Introduction

Sometimes the game can have trouble starting up altogether. Usually this is caused by issues with the local machine rather than a bug/issue with the game.

X4 was to our knowledge the first game which shipped exclusively with Vulkan support which is a very new cross platform graphics API and a replacement for OpenGL/Mental/DirectX (or more specifically Direct3D). Being considered the next gen graphics API which is likely to become more and more popular for other games as well, there are specific issues a user can run into which only applies to games using the Vulkan API. Therefore, it's not uncommon that you don't have an issue with starting all your other games but have difficulties getting X4 to startup correctly.

This page should help you solving the most common mishaps by yourself.

Common Linux (GOG) startup issue

A common installation issue especially on Linux when having purchased the game through GOG is a missing Vulkan runtime. Details how to solve this can be found here.

Exitcodes

When you try to start the game, it performs some early startup checks and if it determines a setup issue, will provide you with a popup like the following one which provides you with instructions on how to resolve the problem yourself:

These instructions are provided specifically for the issue which the game identified so you are not presented with random and pointless FAQ steps which might apply to resolve other situations but won't help with the specific issue at hand. In 90% of the cases the instructions on these popups will solve the issue. Important to recognize here is that at the end it states the exitcode of the startup error (Exitcode 212 in the screenshot above).

In addition to that, your browser might popup and open a link with additional instructions. That page contains more detailed descriptions which might apply in rarer cases and also provide more details about how to apply the troubleshooting steps presented in the popup. Users who previously ran into the same issue might have also provided comments which solved the issue for them.

In certain cases the browser might not bring up the troubleshooting page (f.e. if you have "internet security" software installed which prevents the game from opening the link in the browser). In such cases, you can use the list linked below to bring up the detailed troubleshooting steps:

Crash Errors and Information

Startup issues without exitcodes

In very specific circumstances the game cannot reliably pre-detect error conditions before the startup failure occurs. In these cases you might not see a popup at all but instead get redirected to a troubleshooting page with the descriptions on how to solve the problem. In these cases please follow the instructions on the page.

Obviously there can be cases where you won't get redirected to the troubleshooting page at all (f.e. if your security software blocked the attempt to open the page). From your point of view this situation will appear as if you start the game and nothing happens. If this occurs, please follow the instructions on this troubleshooting page to distinguish between the cases where bringing up the redirect page simply didn't work or whether you ran into the specific issue pointed out on that page.

If you followed the instructions on that page and figured out these didn't apply to you, you can also give it a blind shot and look at the following list of troubleshooting pages which don't have an exitcode assigned:

Startup ErrorDetailed Troubleshooting Page
Missing Vulkan Runtime X4-313 - Getting issue details... STATUS
Avest 3rd-party tool incompatibility X4-104 - Getting issue details... STATUS
Unsupported Intel graphics card issue X4-18 - Getting issue details... STATUS
NVIDIA driver startup error X4-272 - Getting issue details... STATUS
Steamoverlay related startup error X4-277 - Getting issue details... STATUS
Steamoverlay related startup error (type 2) X4-278 - Getting issue details... STATUS
Steamoverlay related startup error (type 3) X4-355 - Getting issue details... STATUS
Vulkan specific startup error X4-353 - Getting issue details... STATUS
3rd-party tool device creation interference X4-505 - Getting issue details... STATUS

Requesting further support

If you still end up being unable to start the game, please send a mail to prioritysupport@egosoft.com with the Subject: "Undefined startup issue" and attach the crash dump file to your mail. This page explains how to locate the crash dump file: Crash Reports and Crash Dumps

Please be aware that this support channel is solely intended to resolve issues with starting up the game. If you run into any other type of problem, please use our troubleshooting section in the official forums to tackle the issue you have.

2 Comments

  1. Anonymous

    zusammenfassung " Teranische S Klasse schiffe mit dem verhalten "Wiederholungsbefehle" (3 bereiche die "Gegner angreifen" beinhalteten) sind nicht in der lage umgerüstet oder an ausrüstungsdocks repariert zu werden bis das verhalten zurückgesetzt wurde"


    ja moooin, kurze Frage. ich hab soeben meinen ersten Terranischen jäger bei meinen verbündeten den Segaris pionieren gekauft. gleich 3  an der zahl und mein persönliches takoba spielzeug natürlich noch lackiert.
    nun hab ich diese benutzt um bei ZYA einwenig rep zu farmen mit xenon abschüssen. der Xenon K hat mich auch gleich mit ner breitseite auf 60 % hülle runtergeballert also zog ich die s klasse schiffe wieder zurück

    ich weiss nich ob es relevant ist aber ich füge noch hinzu, das ich diese Takoba schiffe umbenannt habe in "Tako Bre Fox, Tako Falco und Tako Slippy"

    Jedenfalls lauf ich gerade in folgendes problem

        1. jeder dieser schiffe kann weder repariert noch ausgerüstet werden.ich hielt es zunächst für ein terraner spezifisches problem  und dachte mir ok, vieleicht hat keiner ausser sie selbst die technologie zur reperatur von Terranischen schiffen
          oder dachte mir , vieleicht lassen sich terranische S Klasse schiffe generell nich reparieren und das sei ne rassenspezifische geschichte aber ich konnte dazu keine beiträge in den foren finden also gehe ich davon aus das es sich um einen Bug handeln muss oder?

          kein Ausrüstungsdock ist im Stande, meine angedockten schiffe zu erkennen. wenn man auf Ausrüsten repaireren klickt, sind alle felder ausgegraut und schiffe sind nicht sichtbar. (als stünde kein schiff auf dem Dock)

          auch auf der Galaxiekarte wird einem nirgends die option gegeben "Auszurüsten oder zu reparieren" die einzige option die ich habe ist "Schiff verkaufen".

          ich hab das spiel mal neugestartet und dieser "fehler" ist nach wie vor vorhanden.

          Die erweiterungen "Split Vendetta Version 1 Datum : 2020-03-31"  und "Wiege der Menschheit Version 1 Datum "2021-03-16 " sind eingeschaltet.
          Ansonsten ist alles Vanilla.


          hmm möglicherweise werden die schiffe wegen der umbenennung nicht erkannt... ich kaufe ein neues schiff und versuche es anschließend "umzurüsten" mal sehen was passiert

          ergebniss:
          testsubjekt Takoba, 36 sekunden bauzeit: ergebniss

          nach fertigstellung des baus, ist es möglich ein anderes Ausrüstungsdock auszuwählen und das schiff umzurüsten.
          folgende schritte wurden repliziert (die bewegungsabläufe die mit den ersten 3 schiffe gemacht wurden:

          schiff wurde ausgewählt, und auf "Greife gegner im gebiet an" gesetzt. nach abschluss dieser aufgabe wurde getestet. funktioniert noch
          es wurde sich an bord des schiffes teleportiert, das steuer übernommen, zu einem automatischen wegpunkt geflogen und das schiff zurück in die hände der KI gelegt. funktioniert noch
          letzter test... das schiff wird umbenannt.... FUNKTIONIERT IMMER NOCH

        lol ich hab herrausgefunden wie ich die schiffe wieder umrüstbar mache... aber ich muss ehrlich sagen das mir unklar war oder ist, das das so sein soll....
        die schiffe hatten nachwievor das verhalten "wiederholungsbefehle" ausgewählt... und scheinbar hat dies verhindert, das ich selbst manuel steuernd das schiff in kein ausrüstungsdock schicken konnte...
        ich hab sogar versucht das schiff mal ins lager ein und wieder ausfahren zu lassen ohne das es eine wirkung hatte...
        soll das so sein oder ist das ein bug??  


     

  2. Anonymous

    es ist fast so als hätte das spiel gewollt das ich zu tako Fox, Tako Falco und Tako Slippy noch Tako Peppy hinzufüge hehe.
    ich würde darauf tippen das dies auf unbedachtes  coding zurückzuführen ist... denn ich denke dieser "Bug" tritt dann ein wenn die KI den auftrag des umrüstens nicht erkennt... die wiederholungsbefehle berufen sich ausschlieslich auf die aufgabe von wegpunkt A zu wegpunkt B zu fliegen und dort option a b oder c auszurühren... und die variablen bei umrüstungen sind so zahlreich das dem keine klare option zugeteilt werden kann, und das sorgt dann dafür das das ausrüstungsdock die schiffe nicht mehr als "anwesend" erkennt. ich gehe sogar noc hweiter und vermute, das ihr euch hier eine "ecke offen" gelassen habt. weil ihr anfangs nicht sicher wart wie ihr das problem der beschädigung von patroullie schiffen läsen wollt.... ich wette es wäre einmal eine option gewesen für schiffe die im "wiederholungsbefehl" auftragsketten haben regelmässige Reperaturaufträge einzuführen. kann das sein? 
    das macht mich natürlich jetzt neugierig... ich werde austesten ob ich schiffe im wiederholungsauftrag  bei beschädigung darauf "programmieren" kann, das sie "ausschliesslich reperaturen und keine umrüstungen" selbstständig ausführen können.  wenn das funktioniert, würde ich den Bug umbenennen in Easter Egg und damit klicks auf youtube kassieren haha

     

Write a comment...